Tag Archives: ZF2

Zend Framework 1.12.14, 2.4.6, and 2.5.2 Released!

The Zend Framework community is pleased to announce the immediate availability of: Zend Framework 1.12.14 Zend Framework 2.4.6 Zend Framework 2.5.2 You can download the releases from the Zend Framework site: http://framework.zend.com/downloads/latest These releases contain a critical security fix. Security Fix Zend Framework versions 1.12.14, and 2.4.6, and 2.5.2 introduced fixes for ZF2015-06, a serious vulnerability in ZendXml when used… Read more »

Apigility 1.3.1 Released!

We’ve just released Apigility 1.3.1, which you can download from the Apigility website: https://apigility.org/download If you are already using Apigility, you can update your project using Composer:

This release fixes a few minor issues discovered following the 1.3.0 release, as well as fixes a security vulnerability. Security Fix A security vulnerability was reported against zf-oauth2, with a potential user… Read more »

Apigility 1.2.0 and 1.3.0 Released!

Today, we released two new versions of Apigility: Apigility 1.2.0 Apigility 1.3.0 Apigility 1.2.0 brings in a number of new features, including Docker support, API Blueprint support, better error handling, and new features for REST and RPC services. Apigility 1.3.0 is exactly the same as 1.2.0, but with one key difference: it updates the minimum supported PHP version from 5.3.23… Read more »

Zend Framework 2.5.1 Released!

Note: this post originally appeared on the ZF Blog On the heels of yesterday’s 2.5.0 release, today we’ve released Zend Framework 2.5.1! To update, use Composer:

Changes The only issue reported against 2.5.0 was a blocker for many: with the shift to ZF becoming a metapackage, one component, zend-ldap, had a hard requirement on a specific PHP extension (ext/ldap),… Read more »

Zend Framework 2.5.0 Released!

Note: this post was originally posted on the Zend Framework blog. Today we’ve released Zend Framework 2.5.0! I’m not going to provide a link to the downloads page, as this release marks a radical change for Zend Framework 2: as of this release, all components are now developed in their own separate repositories, and Zend Framework is itself essentially only… Read more »

Apigility 1.1.1 Released!

We’re happy to announce the immediate availability of Apigility 1.1.1! This is our first maintenance release on the 1.1 series, and incorporates feedback received immediately following the 1.1.0 release. Among the important updates: Doctrine-Connected services now support the Doctrine Mongo Object Document Manager! Fixes to how packaging is triggered to ensure it works out-of-the-box. “Growl“-style notifications to let you know… Read more »

Apigility 1.1.0 Released!

We’re pleased to announce the immediate release of Apigility 1.1.0! Pick up your copy here: https://apigility.org/download There are a ton of new features, but the most visible are: A brand new UI! We’ve rewritten the UI from scratch to get better performance, provide better responsiveness, and bring the most-required information to your fingertips. Doctrine-Connected REST service creation (if the zfcampus/zf-apigility-doctrine… Read more »

Zend Framework 2.4.0 RELEASE CANDIDATE 3 Released

I’ve just tagged ZF 2.4.0rc3, and I NEED YOUR HELP! This is our third release candidate. The primary changes pushed include: Updating our Composer autoloading rules to use PSR-4 Ensuring all code will execute cleanly on PHP 7 This latter point has meant renaming a number of classes that have names that are (or will soon become) reserved keywords in… Read more »

Zend Framework 2.4.0 RELEASE CANDIDATE 2 Released

I’ve just tagged ZF 2.4.0rc2, and I NEED YOUR HELP! This is our second release candidate, and we hope to make it the last one before pushing a stable 2.4 release. You can help us by testing your applications under 2.4.0rc2; run “composer update zendframework/zf2” in your application, and run any unit or acceptance tests you might have. If you… Read more »

Zend Framework 2.4.0 RELEASE CANDIDATE 1 Released

I’ve just tagged ZF 2.4.0rc1, and I NEED YOUR HELP! If you are using Composer to install Zend Framework, please update your ZF2 version to 2.4.0rc1, and test your application. Let us know if you have any issues: Are there any new breakages? Are you seeing unexpected behavior? Are extensions you’ve made no longer working? etc. We’re aware of a… Read more »